PHP 5.3 : erreur sur la fonction date()

Vignette_PHP

Voici 2 méthodes pour régler l’erreur :
Warning: date() [function.date]: It is not safe to rely on the system’s timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier.

1 – Vous avez accès au PHP.ini

Editez votre fichier php.ini (son emplacement diffère selon les installations, il peut être là /etc/php.ini ou là /etc/php5/apache2/php.ini
Et décommentez la ligne date.timezone en y ajoutant votre zone, ici ‘Europe/Paris’

2 – Vous n’avez pas accès au PHP.ini

Il suffit alors dans vos pages PHP d’ajouter la définition de votre zone :

Sinon il y a aussi...